"An Error Occurred While Updating Last Epoch"

An Error Occurred While Updating Last Epoch

This is a generic error message which signifies that Steam cannot complete the update process.

We recommend the following troubleshooting steps;

Unfortunately, in some cases it may be necessary to re-install the game.

Did this answer your question? Thanks for the feedback There was a problem submitting your feedback. Please try again later.

Still need help? Contact Us Contact Us