Distro Support for Linux

Similar to many games, we officially support the Ubuntu distribution. That said, Last Epoch should work on most Linux distributions provided that you are using a 64-bit version.

We’d typically expect the distro you use to play less of a factor than which driver you use and how up-to-date it is. Nevertheless, we highlight Ubuntu as that is what we use for testing.

Using a distro other than Ubuntu doesn’t mean that we won’t try to assist you with issues you encounter – nor does it mean we’ll refuse to accept bug reports from you. All it means is that we may not have the ability to offer detailed step-by-step instructions due to differences between various distros and DEs, and for some issues it may take longer (or not be possible) for us to resolve them. We’re a small team with limited resources.

Did this answer your question? Thanks for the feedback There was a problem submitting your feedback. Please try again later.

Still need help? Contact Us Contact Us