System Requirements

As Last Epoch is still in development, these are approximate and may vary over time.


Minimum System Requirements

  • Windows 7 or Ubuntu 16.04
  • i5 2500 or FX 4350
  • 6+ GB RAM
  • GTX 660 Ti or R9 270 (2+ GB VRAM)
  • 20 GB space available, SSD


Recommended System Requirements

  • Windows 10 or Ubuntu 20.04
  • i5 6500 or Ryzen 3 1200
  • 8+ GB of RAM
  • GTX 1060 or RX 480 (4+ GB VRAM)
  • 20 GB space available, SSD


Minimum System Requirements (Legacy Client)

  • MacOS 10.12
  • i5 2500 or FX 4350
  • 6+ GB RAM
  • GTX 660 Ti or R9 270 (2+ GB VRAM)
  • 20 GB space available, SSD


Recommended System Requirements (Legacy Client)

  • MacOS 10.15
  • i5 6500 or Ryzen 3 1200
  • 8+ GB of RAM
  • GTX 1060 or RX 480 (4+ GB VRAM)
  • 20 GB space available, SSD
Did this answer your question? Thanks for the feedback There was a problem submitting your feedback. Please try again later.

Still need help? Contact Us Contact Us